{"dataType": "CVE_RECORD", "dataVersion": "5.2", "cveMetadata": {"cveId": "CVE-2026-123539", "assignerOrgId": "83251b91-4cc7-4094-a5c7-464a1b83ea10", "state": "PUBLISHED", "assignerShortName": "VulnCheck", "dateReserved": "2026-11-06T00:48:46.279Z", "datePublished": "2026-11-08T01:37:45.918Z", "dateUpdated": "2026-11-08T01:37:45.918Z"}, "containers": {"cna": {"providerMetadata": {"orgId": "83251b91-4cc7-4094-a5c7-464a1b83ea10", "shortName": "VulnCheck", "dateUpdated": "2026-11-08T01:37:45.918Z"}, "datePublic": "2026-10-22T00:00:00.000Z", "title": "OpenAM before 16.1.4 Stored XSS via OAuth 2.0 Consent Page Display Name", "descriptions": [{"lang": "en", "value": "OpenAM before 16.1.4 contains a stored cross-site scripting vulnerability that allows privileged attackers to inject script by placing markup in a user's display name. When the victim reaches the OAuth 2.0 / OpenID Connect consent page, the unencoded name executes script that can steal the OpenAM session cookie to impersonate the user."}], "problemTypes": [{"descriptions": [{"lang": "en", "description": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')", "cweId": "CWE-79", "type": "CWE"}]}], "affected": [{"vendor": "OpenIdentityPlatform", "product": "OpenAM", "defaultStatus": "unaffected", "packageURL": "pkg:maven/org.openidentityplatform.openam/openam-oauth2", "versions": [{"version": "0", "status": "affected", "versionType": "semver", "lessThan": "16.1.4"}, {"version": "16.1.4", "status": "unaffected", "versionType": "semver"}]}], "cpeApplicability": [{"nodes": [{"operator": "OR", "negate": false, "cpeMatch": [{"vulnerable": true, "criteria": "cpe:2.3:a:openidentityplatform:openam:*:*:*:*:*:*:*:*", "versionEndExcluding": "16.1.4"}]}]}], "metrics": [{"format": "CVSS", "cvssV4_0": {"version": "4.0", "vectorString": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N", "attackVector": "NETWORK", "attackComplexity": "LOW", "attackRequirements": "NONE", "privilegesRequired": "HIGH", "userInteraction": "PASSIVE", "vulnConfidentialityImpact": "LOW", "vulnIntegrityImpact": "LOW", "vulnAvailabilityImpact": "NONE", "subConfidentialityImpact": "LOW", "subIntegrityImpact": "LOW", "subAvailabilityImpact": "NONE", "baseScore": 4.8, "baseSeverity": "MEDIUM"}}, {"format": "CVSS", "cvssV3_1": {"version": "3.1", "vectorString": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N", "attackVector": "NETWORK", "attackComplexity": "LOW", "privilegesRequired": "HIGH", "userInteraction": "REQUIRED", "scope": "CHANGED", "confidentialityImpact": "LOW", "integrityImpact": "LOW", "availabilityImpact": "NONE", "baseScore": 4.8, "baseSeverity": "MEDIUM"}}], "references": [{"url": "https://github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-v6hq-3cfh-5gr6", "tags": ["vendor-advisory"], "name": "GitHub Security Advisory (GHSA-v6hq-3cfh-5gr6)"}, {"name": "VulnCheck Advisory: OpenAM before 16.1.4 Stored XSS via OAuth 2.0 Consent Page Display Name", "tags": ["third-party-advisory"], "url": "https://www.vulncheck.com/advisories/openam-before-16.1.4-stored-xss-via-oauth-2.0-consent-page-display-name"}], "credits": [{"lang": "en", "value": "vharseko", "type": "remediation developer"}, {"lang": "en", "value": "maximthomas", "type": "remediation reviewer"}, {"lang": "en", "value": "tsujiguchitky", "type": "remediation reviewer"}, {"lang": "en", "value": "manus-use", "type": "reporter"}], "x_generator": {"engine": "vulncheck-endgame"}}}}